Saturday, November 27, 2010

Windows Phone 7 Developer Unlock



(1) Install this certificate in your Windows Phone 7 via IE :

(2) Download and install this registration key in your Windows 7 OS

(3) Download and run this program in Windows 7 OS

Other Hacks
copy files to WP7 device in Windows Explorer

USB Tethering

Thursday, November 25, 2010

Windows Phone 7 Developer Registration Step 2 Error

see here

Error in Step 2 while registering
We are currently tracking an issue developers may experience while registering for App Hub where they receive an error including the following text:

We have detected an error while processing the page you were looking for.

· If you reside in Hong Kong, we are aware of this issue but do not have any workarounds available. We are investigating this and will update this announcement as we find more information.

Saturday, November 20, 2010

香港天氣及日曆 gadgets (windows 7)

Stock 3 gadget is here

Sunday, November 14, 2010

How to replace gnutar and gsed for Mac OS X

Install MacPorts

Install gnutar

sudo port install gnutar

Install gsed

sudo port install gsed

Replace tar and sed in Mac OS X

sudo mv /usr/bin/tar /usr/bin/darwintar
sudo ln -s /opt/local/bin/gnutar /usr/bin/tar

sudo mv /usr/bin/sed /usr/bin/darwinsed
sudo ln -s /opt/local/bin/gsed /usr/bin/sed

or you can build from source

Sunday, November 7, 2010

iPA God

The so called iPA God is just using the developer's certificate to re-codesign the cracked app and install on non-jailbreaked iPhone.

Staring from iOS 4.0, provisioning profile and app can be distributed and installed via WebServer

You can simply add this in the WebServer and install the app via http

<a href="">Install Provisioning Profile</a><br/>
<a href="itms-services://?action=download-manifest&url=">Install MyApp</a>

The content of MYApp.plist is

MyApp.plist Select all

<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE plist PUBLIC "-//Apple//DTD PLIST 1.0//EN" "">
<plist version="1.0">


WhatsApp for iPad

The new version v2.5.11 doesn't work for iPad 3G

You have to install 2.5.3 then upgrade to 2.5.11